Ферум

Кардшаринг на Dvb картах под Linux

В теме 1 242 сообщения

Lakan попробуй сменить браузер на "мазилу фаерфокс"

Поделиться сообщением


Ссылка на сообщение

Lakan попробуй сменить браузер на "мазилу фаерфокс"

Им и пользуюсь, но при попытке скачать получаю такое сообщение:

Сообщение форума

Обнаружена ошибка. Если вам неизвестны причины ошибки, попробуйте обратиться к разделам помощи.

Причина:

Некоторые требуемые файлы отсутствуют. Если вы хотели просмотреть тему, возможно эта тема перемещена или удалена. Вернитесь назад и попробуйте снова.

Поделиться сообщением


Ссылка на сообщение

Lakan

файлы отсутствуют.

значит удалил сам пользователь,который выложил.

Поделиться сообщением


Ссылка на сообщение

значит удалил сам пользователь,который выложил.

Нет я не удалял, видимо просто какие то технические проблемы на форуме, но это поправимо.

По вопросу как вылечить kaffeine от глюков. сносим его через sinaptic или через консоль, удобно через миднаит коммандер почистить рекурсивно каталоги, которые он после себя оставил. Переустанавливаем пакет libxine1-ffmpeg с зависимостями и ставим kaffeine заново. Кстати для доступа к пакетам кодеков у меня подцеплены репы медибунту, дебайн мультимедиа, ну и упомянутый лауч. В целесообразности подключения последнего для получения кодеков честно говоря я теперь сильно усомнился, так как HD каналы в Ubuntu 9.10 у меня просто не пошли совсем а в логе error h264 decoder на 9.04 у меня этот репо был отключен сразу после установки дров на видюху 185 драйвер. Теперь на 9.10 стоит 190 драйвер - надо видеть чтобы оценить как работает с этим драйвером compiz а вот а каналами проблема. Кстати по поводу посмотреть лог просто запускаем kaffeine из консоли одноимённой командой и смотрим чего ему там не нравится если есть малейшее представление о шаринге и капельку понимаете по английски (я сам немецкий в школе учил больше 20ти лет назад) всё сразу становится понятно. Жёсткой привязки идента к каналам нет, идент указывается в последнем пункте строки настройки плагина.

У самого есть вопрос кто нибудь разобрался с новым kaffeine 1.0 pre2 ?

kaffeine_sc_0.4.1_1_i386.deb.zip

kaffeine_sc_plugin_0.3.7.zip

kaffeine_sc_plugin_0.3.8.zip

kaffeine_sc_0.3.9svn.zip

kaffeine_sc_plugin_0.4.0.zip

kaffeine_sc_0.4.1.zip

Поделиться сообщением


Ссылка на сообщение

Спасибо Ферум , все скачалось....

Поделиться сообщением


Ссылка на сообщение

Подскажите, а под гномом kaffeine работает или надо KDE?

Зы Поставил только сейчас убунту, както все непривычно, даже не знаю с чего начать.

Поделиться сообщением


Ссылка на сообщение

Подскажите, а под гномом kaffeine работает или надо KDE?

Зы Поставил только сейчас убунту, както все непривычно, даже не знаю с чего начать.

библиотеки kde3-libs надо будет поставить

Поделиться сообщением


Ссылка на сообщение

Помогите установить mercurial

Пишет

mercurial:

Зависит: python (<2.6), но будет установлен 2.6.4-0ubuntu1

Ubuntu 9.10

Поделиться сообщением


Ссылка на сообщение

Смотрю ТВ под Линуксом, используя VDR (1.6.0) и sc-плагин (0.8.5-1). Для настроек выбирал newcam. Со вчерашнего дня шара работать перестала. Посмотрел на странице настроек, а так вместо newcam стоит newcam2. Пинг на сервер быстрый. Не понимаю совершенно, в чем дело. Буду благодарен за любою помощь.

Заранее спасибо

Поделиться сообщением


Ссылка на сообщение
golub , ты помнится баловался мандривоЙ и вроде прилично в ней разобрался? Ubuntu на мой взгляд дружелюбней и форум лучше ( mandriva я тоже пробовал) Kaffeine, Krusader, K3b, Kopete и всё прочее прекрасно работают и под гномом, каталог KDE в корневой папке естественно образуется автоматом при установке первого кдешного приложения зависимости естественно тоже тянет автоматом. С каффайном из репозитория правда пока непонятки, родной плагин по ходу не работает, приходится ставить старую версию 0.8.8 вручную.

Поделиться сообщением


Ссылка на сообщение

Да настроил уже, но как-то все очень непривычно.

Поделиться сообщением


Ссылка на сообщение

Кстати, на убунту 9,10 вы плагин компилили или ставили deb-пакет?

Просто по умолчанию стоит компилятор версии 4.4 и

во время компиляции плагина он пишет, что старые команды будут проигнорированы.

Хотел поставить параллельно старый gcc 3.3, но его нет в стандартном репозитарии.

Если кто знает, как его добавить, подскажите.

Поделиться сообщением


Ссылка на сообщение

Кстати, на убунту 9,10 вы плагин компилили или ставили deb-пакет?

Я пробовал компилить куча ругательств, плюнул поставил собственное изделие из предидущей 9.04 дебпакетом. Не удивительно вобщем то, ведь и kaffeine из репо по ходу шару не поддерживает, приходится юзать старый. По поводу установки старых пакетов геморойно, но возможно вручную, правда если удастся собрать все зависимости http://packages.ubuntu.com/ интересный момент я понял , если какая то библиотека исчезла в новом дистрибутиве, то здесь легко понять каой библиотекой её заменили.

Поделиться сообщением


Ссылка на сообщение

Привет всем активным участникам раздела..!!!

Хочу поделиться о наболевшем, может поможете добрым советом..

Суть проблемы такова, настроил шару +++ на Ubuntu9.04 + kaffeine 0.8.8 +kaffeine-sc-4.1.1+nvidia 180 каналы показываю да не все: :(

Не показывают такие каналы как: Кинохит, Премьера, Кинорейс 1-3 и (др)., перечислел только ходовые какие см.

Ради интереса полез в лог kaffeine включив при этом нерабочий канал..

Ошибка следующая:

cTripleDes::PadMessage : message overflow in cTripleDes::PadMessage

NewCSClient::SendMessage : PadMessage failed

NewCSClient::processECM : failed sending ecm

Softcam : Can't read SoftCam.Key !

Reading PMT

Found Viaccess id 40600

Found Viaccess id 30600

Found Viaccess id 23700

Found Viaccess id 40610

buflen : 228

81 70 e1 00 90 03 02 37 08 9f 30 47 45 4f 5e 53 45 52 56 52 55 53 2a 55 4b 52 23 48 49 4f 5e 33 45 5d 56 52 55 63 2a 51 4b 52 23 47 45 2f 5e 53 85 52 56 52 59 53 2a 55 44 52 23 e0 01 c0 e1 04 3b 53 99 c4 e1 04 3b 53 9b c7 e1 04 3b 53 e7 6a e1 04 3b 53 77 ea e1 04 3b 53 c9 94 e1 04 3b 53 da b2 e1 04 3b 53 83 6b e1 04 3b 53 65 7e e1 04 3b 53 b1 be e1 04 3b 53 ab dc e1 04 3b 53 84 d3 e1 04 3b 53 ca d5 e1 04 3b 53 82 92 e1 04 3b 53 73 bd e1 04 3b 53 75 6d e1 04 3b 53 c6 6f e1 04 3b 53 c7 d3 e1 04 3b 53 67 9a e2 03 3b 53 08 e2 03 3b 53 23 e2 03 3b 53 09 e2 03 3b 53 2d e2 03 3b 53 8f e2 03 3b 53 93 ea 10 c6 8c 88 7f 3b 9e 8d 60 6d 59 41 83 bb 13 30 a4 f0 08 09 59 a7 0c 8d 33 fc 23

No Viaccess key found for : id : 023700 keynr : 08

и так до бесконечности….

В моем понятии что-то с длинной ключа и его отправкой, могу и ошибаться….

Прочитал тут на форуме, что это лечится увеличением длинны буфера ECM в kaffeine-sc.../src/ в файле cardclient.h правится 17 строка с #define CWS_NETMSGSIZE 240 на #define CWS_NETMSGSIZE 480

Залез в исходники kaffeine-sc нашел строку , изменил, скомпилил без ошибок сказать, честно не обошлось, поставил и тут ОБЛОМ каналы как не показывали, так и не показывают…

Зашел я так сказать в тупик - толи это из-за ошибок при сборке или еще чего..

Вопрос у меня к ФЕРУМ kaffeine_sc_0.4.1_1_i386.zip который Ты сам собирал открывает каналы какие перечислены ?

Может кто-нибудь поделится рабочим плугином..

Поделиться сообщением


Ссылка на сообщение

На этой странице выше выложен деп-пакет, скачайте и установите.

Поделиться сообщением


Ссылка на сообщение

Спасибо Ферум твоя сборка kaffeine_sc_0.4.1_1_i386.deb решила кучу проблем.. :rolleyes:

Поделиться сообщением


Ссылка на сообщение

Смотрю ТВ под Линуксом, используя VDR (1.6.0) и sc-плагин (0.8.5-1). Для настроек выбирал newcam. Со вчерашнего дня шара работать перестала. Посмотрел на странице настроек, а так вместо newcam стоит newcam2. Пинг на сервер быстрый. Не понимаю совершенно, в чем дело. Буду благодарен за любою помощь.

Заранее спасибо

В одной конфигурации у меня SUSE 11.2 KDE4.3 Profred 7300 Nvidia 8600 GTS Core2duo 8400 MSIP45neo . Kaffeine 1pre каналы залочил, но плагин sc не смог подключить. Поставил Kaffeine 8.8 , собрал плугин, все заработало. Решил поковыряться с vdr, т.к. старый каффейн притащил много из KDE3. VDR 1.6.0 и xine plugin есть в дистрибутиве. SC собрал предпоследнюю версию (последняя не прошла тест FFDesca). Положил sc.conf в ./vdr/plugins :

newcamd2:cserv14.net:10000:0/0500/ffff:xxxxxxx:xxxxxxx:0102030405060708091011121314

Xine vdr открытые каналы кажет, на закрытые перестал ругаться, но на них картинки нет. Может, строка sc.conf не того формата ? Или sc.conf нужно еще куда-то положить ? И где посмотреть/изменить ЕСМ, если надо. На исчезнувшем форуме было все про это.

Поделиться сообщением


Ссылка на сообщение

Извиняюсь, не sc.conf, а cardclient.conf

Поделиться сообщением


Ссылка на сообщение

А если просто newcamd а не newcamd2 попробовать. У меня по newcamd без проблем работает и правда файл cardclient.conf лежит в /etc/vdr/plugins/sc/ т к при запуске vdr явно указываю путь к конфигурационным файлам -c /etc/vdr

Поделиться сообщением


Ссылка на сообщение

А если просто newcamd а не newcamd2 попробовать. У меня по newcamd без проблем работает и правда файл cardclient.conf лежит в /etc/vdr/plugins/sc/ т к при запуске vdr явно указываю путь к конфигурационным файлам -c /etc/vdr

пробовал и newcamd, хотя провайдер дал newcamd2. Правда, cardclient.conf лежит в /etc/vdr/plugins . Стартую я также /usr/sbin/vdr -c /etc/vdr -P "sc" -P "xine-r"

Поделиться сообщением


Ссылка на сообщение

Я думаю, где-то длину ЕСМ подправить надо, а где - не знаю (с 270 до 480)

Поделиться сообщением


Ссылка на сообщение

У меня cardclient.conf лежит в /etc/vdr/plugins/sc

ECM править вот тут в исходниках sc в файле - ./systems/cardclient/newcamd.c

строка - #define CWS_NETMSGSIZE 480

Можно включить в vdr протоколирование плагина в файл

Меню - Настройка- Модули расширения - sc - Протоколирование сообщений -Сообщения в файл

Файл в который писать должен иметь права доступа на запись под кем запущен vdr

Поделиться сообщением


Ссылка на сообщение

У меня cardclient.conf лежит в /etc/vdr/plugins/sc

ECM править вот тут в исходниках sc в файле - ./systems/cardclient/newcamd.c

строка - #define CWS_NETMSGSIZE 480

Можно включить в vdr протоколирование плагина в файл

Меню - Настройка- Модули расширения - sc - Протоколирование сообщений -Сообщения в файл

Файл в который писать должен иметь права доступа на запись под кем запущен vdr

Пересобрал плагин с #define CWS_NETMSGSIZE 480. Положил cardclient.conf в /etc/vdr/plugins/sc.

Судя по логам, все нормально. А картинки нет .

vdr_log.txt

Поделиться сообщением


Ссылка на сообщение

Пересобрал плагин с #define CWS_NETMSGSIZE 480. Положил cardclient.conf в /etc/vdr/plugins/sc.

Судя по логам, все нормально. А картинки нет .

vdr_log.txt

Плагин старый, вот тут последний vdr-sc

пересобери и с ним попробуй

Поделиться сообщением


Ссылка на сообщение

Плагин старый, вот тут последний vdr-sc

пересобери и с ним попробуй

А этот у меня не проходит тест FFdesca при сборке. Я писал, что пробовал его собрать - не получилось,

пришлось откатится. Логи посмотрел ? Там все нормально ?

Поделиться сообщением


Ссылка на сообщение

А этот у меня не проходит тест FFdesca при сборке. Я писал, что пробовал его собрать - не получилось,

пришлось откатится. Логи посмотрел ? Там все нормально ?

Посмотрел, вроде Key получаешь. Какая ошибка при тест FFdesca, процессор какой установлен?

Может стоит попробовать где-то еще тестовый вариант, где точно newcamd а не newcamd2?

Поделиться сообщением


Ссылка на сообщение

Посмотрел, вроде Key получаешь. Какая ошибка при тест FFdesca, процессор какой установлен?

Может стоит попробовать где-то еще тестовый вариант, где точно newcamd а не newcamd2?

В кафейне с newcamd все идет. А при сборке последнего sc :

FAILED COMPARISON OF PACKET 29986

FAILED COMPARISON OF PACKET 29987

FAILED COMPARISON OF PACKET 29988

FAILED COMPARISON OF PACKET 29989

FAILED COMPARISON OF PACKET 29990

FAILED COMPARISON OF PACKET 29991

FAILED COMPARISON OF PACKET 29992

FAILED COMPARISON OF PACKET 29993

FAILED COMPARISON OF PACKET 29994

FAILED COMPARISON OF PACKET 29995

FAILED COMPARISON OF PACKET 29996

FAILED COMPARISON OF PACKET 29997

FAILED COMPARISON OF PACKET 29998

FAILED COMPARISON OF PACKET 29999

make[1]: *** [FFdecsa_test.done] Ошибка 10

Проц по умолчанию. Система Суся 11.2 х 32

Поделиться сообщением


Ссылка на сообщение

gcc 4.4 ? Если да, то надо компилить gcc 4.3 или 3.4. С 4.4 может не собираться

Поделиться сообщением


Ссылка на сообщение

gcc 4.4 ? Если да, то надо компилить gcc 4.3 или 3.4. С 4.4 может не собираться

Я в make ставил и g++, и g4.3++, процессоры тоже пробовал разные (все комбинации, конечно, не перепробовал, но предыдущая версия собирается со значениями по-умолчанию). CXX=`which g++-4.3`. Единственное не пробовал еще

CSAFLAGS ?= -Wall -fPIC -g -mmmx -fomit-frame-pointer -fexpensive-optimizations -funroll-loops

Блин, стояла раньше Суся 11.1 с кде 3.5 - проблем не было. Решил поставить 11.2 с кде 4. И началось. Если что-то не из репозитория, замучаешься собирать.

Поделиться сообщением


Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти