Перейти к содержанию

VDR + XBMC + Ubuntu - это просто!


Рекомендуемые сообщения

Не помогло


LD xbmc.bin

-----------------------

XBMC built successfully

-----------------------

make[1]: Leaving directory `/home/alex/x/xbmc-build/sources/xbmc'

make -j2 -C lib/addons/script.module.pil

make[1]: Entering directory `/home/alex/x/xbmc-build/sources/xbmc/lib/addons/script.module.pil'

make[1]: Leaving directory `/home/alex/x/xbmc-build/sources/xbmc/lib/addons/script.module.pil'

dh_auto_test

Google Test Framework not configured, skipping testsuite check.

dh_testroot

dh_prep

dh_installdirs

dh_auto_install

Copying XBMC binary to /home/alex/x/xbmc-build/sources/xbmc/debian/xbmc/usr/lib/xbmc/

You can run XBMC with the command 'xbmc'

Copying support and legal files...

Done!

Copying system files to /home/alex/x/xbmc-build/sources/xbmc/debian/xbmc/usr/share/xbmc

dh_installml

dh_installdocs

dh_installchangelogs

dh_installexamples

dh_installman

dh_installcatalogs

dh_installcron

dh_installdebconf

dh_installemacsen

dh_installifupdown

dh_installinfo

dh_pysupport

dh_pysupport: This program is deprecated, you should use dh_python2 instead. Migration guide: http://deb.li/dhs2p

dh_installinit

dh_installmenu

dh_installmime

dh_installmodules

dh_installlogcheck

dh_installlogrotate

dh_installpam

dh_installppp

dh_installudev

dh_installwm

dh_installxfonts

dh_installgsettings

dh_bugfiles

dh_ucf

dh_lintian

dh_gconf

dh_icons

dh_perl

dh_usrlocal

dh_link

dh_compress

dh_fixperms

dh_strip

dh_makeshlibs

debian/rules override_dh_shlibdeps

dh_shlibdeps -a -Xdvdplayer

dpkg-shlibdeps: ошибка: информация о зависимостях не найдена для /usr/lib/libGL.so.1 (используется debian/xbmc/usr/lib/xbmc/addons/visualization.glspectrum/opengl_spectrum.vis)

dh_shlibdeps: dpkg-shlibdeps -Tdebian/xbmc.substvars debian/xbmc/usr/lib/xbmc/system/ImageLib-i486-linux.so debian/xbmc/usr/lib/xbmc/system/libcpluff-i486-linux.so debian/xbmc/usr/lib/xbmc/system/libexif-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/libsidplay2-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/timidity-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/SNESAPU-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/nosefart-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/stsoundlibrary-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/vgmstream-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/adpcm-i486-linux.so debian/xbmc/usr/lib/xbmc/system/libcmyth-i486-linux.so debian/xbmc/usr/lib/xbmc/system/hdhomerun-i486-linux.so debian/xbmc/usr/lib/xbmc/xbmc.bin debian/xbmc/usr/lib/xbmc/addons/library.xbmc.pvr/libXBMC_pvr-i486-linux.so debian/xbmc/usr/lib/xbmc/addons/visualization.projectm/projectM.vis debian/xbmc/usr/lib/xbmc/addons/library.xbmc.addon/libXBMC_addon-i486-linux.so debian/xbmc/usr/lib/xbmc/addons/screensaver.rsxs.plasma/Plasma.xbs debian/xbmc/usr/lib/xbmc/addons/visualization.glspectrum/opengl_spectrum.vis debian/xbmc/usr/lib/xbmc/addons/library.xbmc.gui/libXBMC_gui-i486-linux.so debian/xbmc/usr/lib/xbmc/addons/visualization.waveform/Waveform.vis debian/xbmc/usr/lib/xbmc/addons/screensaver.rsxs.euphoria/Euphoria.xbs debian/xbmc/usr/lib/xbmc/addons/screensaver.rsxs.solarwinds/Solarwinds.xbs debian/xbmc/usr/lib/xbmc/xbmc-xrandr returned exit code 2

make: *** [override_dh_shlibdeps] Ошибка 2

HDTV под Linux: Dreambox DM800 HD PVR имидж Nemesis V2.4 MgCamd 1.38+oscam+wicardd

Dreambox DM800 HD Pro (SIM 2.01)  Nemesis V2.3 MgCamd 1.38+oscam+wicardd
Omicom Skystar 4 Debian wheezy amd64 vdr+XBMC-PVR12+wicardd+oscam
Skystar USB HD :

Debian 7 wheezy TDE Trinity kaffeine-trinity 0.8.8 + sasc-ng

    KDE vdr+XBMC

Debian 8 Jessie  MythTV+ffdecsawrapper

Debian 9 Stretch vdr+oscam-emu + KODI
Dreambox 500 s  прошит под небесную шару
Satelite: 4.0W, 4,9E,13E, 36E, 75E, 85,1E, 90E
Русские дебианщики против цифрового слабоумия...

2c1e3141298276e3293ddac5449c0a44.png

Ссылка на сообщение
  • Ответов 3.4т
  • Создана
  • Последний ответ

Топ авторов темы

Топ авторов темы

Изображения в теме

и если не затруднит подразжуйте тупому ламеру про сборку только с ОСКАМ и ДВБАПИ

Oscam собирается легко, а вот с vdr нужно повозиться - для него нужно еще стартовые скрипты писать. Примеры можете посмотреть здесь - git clone https://github.com/AndreyPavlenko/vdr-build.git. Лучше смотреть в бранче 36E (git checkout 36E). Там нету ничего лишнего, все только самое необходимое для 36-го градуса плюс иконки каналов для xvdr. Чтобы собрать скриптом только vdr+dvbapi+oscam создайте файлик build.config с таким содержимым:

ENABLE_SC='false'
ENABLE_OSCAM='true'
# Здесь прописать все что нужно, либо закоментировать
OSCAM_CONFIG_ARGS='--disable all --enable HAVE_DVBAPI MODULE_NEWCAMD'
Ссылка на сообщение

Не помогло

LD	 xbmc.bin
-----------------------
XBMC built successfully
-----------------------
make[1]: Leaving directory `/home/alex/x/xbmc-build/sources/xbmc'
make -j2 -C lib/addons/script.module.pil
make[1]: Entering directory `/home/alex/x/xbmc-build/sources/xbmc/lib/addons/script.module.pil'
make[1]: Leaving directory `/home/alex/x/xbmc-build/sources/xbmc/lib/addons/script.module.pil'
dh_auto_test
Google Test Framework not configured, skipping testsuite check.
dh_testroot
dh_prep
dh_installdirs
dh_auto_install
Copying XBMC binary to /home/alex/x/xbmc-build/sources/xbmc/debian/xbmc/usr/lib/xbmc/
You can run XBMC with the command 'xbmc'
Copying support and legal files...											
Done!
Copying system files to /home/alex/x/xbmc-build/sources/xbmc/debian/xbmc/usr/share/xbmc
dh_installml															
dh_installdocs
dh_installchangelogs
dh_installexamples
dh_installman
dh_installcatalogs
dh_installcron
dh_installdebconf
dh_installemacsen
dh_installifupdown
dh_installinfo
dh_pysupport
dh_pysupport: This program is deprecated, you should use dh_python2 instead. Migration guide: http://deb.li/dhs2p
dh_installinit
dh_installmenu
dh_installmime
dh_installmodules
dh_installlogcheck
dh_installlogrotate
dh_installpam
dh_installppp
dh_installudev
dh_installwm
dh_installxfonts
dh_installgsettings
dh_bugfiles
dh_ucf
dh_lintian
dh_gconf
dh_icons
dh_perl
dh_usrlocal
dh_link
dh_compress
dh_fixperms
dh_strip
dh_makeshlibs
debian/rules override_dh_shlibdeps
dh_shlibdeps -a -Xdvdplayer
dpkg-shlibdeps: ошибка: информация о зависимостях не найдена для /usr/lib/libGL.so.1 (используется debian/xbmc/usr/lib/xbmc/addons/visualization.glspectrum/opengl_spectrum.vis)
dh_shlibdeps: dpkg-shlibdeps -Tdebian/xbmc.substvars debian/xbmc/usr/lib/xbmc/system/ImageLib-i486-linux.so debian/xbmc/usr/lib/xbmc/system/libcpluff-i486-linux.so debian/xbmc/usr/lib/xbmc/system/libexif-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/libsidplay2-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/timidity-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/SNESAPU-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/nosefart-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/stsoundlibrary-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/vgmstream-i486-linux.so debian/xbmc/usr/lib/xbmc/system/players/paplayer/adpcm-i486-linux.so debian/xbmc/usr/lib/xbmc/system/libcmyth-i486-linux.so debian/xbmc/usr/lib/xbmc/system/hdhomerun-i486-linux.so debian/xbmc/usr/lib/xbmc/xbmc.bin debian/xbmc/usr/lib/xbmc/addons/library.xbmc.pvr/libXBMC_pvr-i486-linux.so debian/xbmc/usr/lib/xbmc/addons/visualization.projectm/projectM.vis debian/xbmc/usr/lib/xbmc/addons/library.xbmc.addon/libXBMC_addon-i486-linux.so debian/xbmc/usr/lib/xbmc/addons/screensaver.rsxs.plasma/Plasma.xbs debian/xbmc/usr/lib/xbmc/addons/visualization.glspectrum/opengl_spectrum.vis debian/xbmc/usr/lib/xbmc/addons/library.xbmc.gui/libXBMC_gui-i486-linux.so debian/xbmc/usr/lib/xbmc/addons/visualization.waveform/Waveform.vis debian/xbmc/usr/lib/xbmc/addons/screensaver.rsxs.euphoria/Euphoria.xbs debian/xbmc/usr/lib/xbmc/addons/screensaver.rsxs.solarwinds/Solarwinds.xbs debian/xbmc/usr/lib/xbmc/xbmc-xrandr returned exit code 2
make: *** [override_dh_shlibdeps] Ошибка 2

Ну так у вас все собралось. Упало на dh_shlibdeps - вычисление зависимостей для deb пакета. Попробуйте подредактировать скрипт и пропишите все нерезолвленные через -X.

Ссылка на сообщение

Ну так у вас все собралось. Упало на dh_shlibdeps - вычисление зависимостей для deb пакета. Попробуйте подредактировать скрипт и пропишите все нерезолвленные через -X.

Я счастлив, что могу выполнить make install но хочется deb пакеты а редактировать ваш скрипт мне не по зубам....тут у меня к сожалению пробелы в знаниях.

HDTV под Linux: Dreambox DM800 HD PVR имидж Nemesis V2.4 MgCamd 1.38+oscam+wicardd

Dreambox DM800 HD Pro (SIM 2.01)  Nemesis V2.3 MgCamd 1.38+oscam+wicardd
Omicom Skystar 4 Debian wheezy amd64 vdr+XBMC-PVR12+wicardd+oscam
Skystar USB HD :

Debian 7 wheezy TDE Trinity kaffeine-trinity 0.8.8 + sasc-ng

    KDE vdr+XBMC

Debian 8 Jessie  MythTV+ffdecsawrapper

Debian 9 Stretch vdr+oscam-emu + KODI
Dreambox 500 s  прошит под небесную шару
Satelite: 4.0W, 4,9E,13E, 36E, 75E, 85,1E, 90E
Русские дебианщики против цифрового слабоумия...

2c1e3141298276e3293ddac5449c0a44.png

Ссылка на сообщение

Ан9рей

override_dh_shlibdeps:

dh_shlibdeps -a -Xdvdplayer

override_dh_builddeb:

dh_builddeb --destdir=../../distribs --

это конец скрипта где то здесь править? Как правильно?

HDTV под Linux: Dreambox DM800 HD PVR имидж Nemesis V2.4 MgCamd 1.38+oscam+wicardd

Dreambox DM800 HD Pro (SIM 2.01)  Nemesis V2.3 MgCamd 1.38+oscam+wicardd
Omicom Skystar 4 Debian wheezy amd64 vdr+XBMC-PVR12+wicardd+oscam
Skystar USB HD :

Debian 7 wheezy TDE Trinity kaffeine-trinity 0.8.8 + sasc-ng

    KDE vdr+XBMC

Debian 8 Jessie  MythTV+ffdecsawrapper

Debian 9 Stretch vdr+oscam-emu + KODI
Dreambox 500 s  прошит под небесную шару
Satelite: 4.0W, 4,9E,13E, 36E, 75E, 85,1E, 90E
Русские дебианщики против цифрового слабоумия...

2c1e3141298276e3293ddac5449c0a44.png

Ссылка на сообщение

Ан9рей

override_dh_shlibdeps:

dh_shlibdeps -a -Xdvdplayer

override_dh_builddeb:

dh_builddeb --destdir=../../distribs --

это конец скрипта где то здесь править? Как правильно?

Если вы еще не сделали clean, то попробуйте в debian/rules прописать:

dh_shlibdeps -a -Xdvdplayer -XlibGL

После чего, выполните fakeroot dh binary.

В скрипте тоже нету ничего сложного, там надо подредактировать одну строку:

echo "\noverride_dh_shlibdeps:\n\tdh_shlibdeps -a -Xdvdplayer" >> debian/rules
Ссылка на сообщение

Если вы еще не сделали clean, то попробуйте в debian/rules прописать:

dh_shlibdeps -a -Xdvdplayer -XlibGL

После чего, выполните fakeroot dh binary.

В скрипте тоже нету ничего сложного, там надо подредактировать одну строку:

echo "\noverride_dh_shlibdeps:\n\tdh_shlibdeps -a -Xdvdplayer" >> debian/rules
не прокатило

собралось с

dh_shlibdeps -i -Xdvdplayer -XlibGL.so1

всё в один пакет, неужели так было задумано?

HDTV под Linux: Dreambox DM800 HD PVR имидж Nemesis V2.4 MgCamd 1.38+oscam+wicardd

Dreambox DM800 HD Pro (SIM 2.01)  Nemesis V2.3 MgCamd 1.38+oscam+wicardd
Omicom Skystar 4 Debian wheezy amd64 vdr+XBMC-PVR12+wicardd+oscam
Skystar USB HD :

Debian 7 wheezy TDE Trinity kaffeine-trinity 0.8.8 + sasc-ng

    KDE vdr+XBMC

Debian 8 Jessie  MythTV+ffdecsawrapper

Debian 9 Stretch vdr+oscam-emu + KODI
Dreambox 500 s  прошит под небесную шару
Satelite: 4.0W, 4,9E,13E, 36E, 75E, 85,1E, 90E
Русские дебианщики против цифрового слабоумия...

2c1e3141298276e3293ddac5449c0a44.png

Ссылка на сообщение

всё в один пакет, неужели так было задумано?

Да, все в один пакет. Если хотите разложить по пакетам, то нужно каждый пакет описать в debian/control и положить в debian/ файлы <имя пакета>.install со списком файлов, которые надо включить в пакет. Пример можно посмотреть здесь - https://github.com/xbmc/xbmc-packaging.git. Но я не вижу смысла с этим заморачиваться. Так как пакет собирается для себя, а не для всех и на все случаи жизни, то лучше в CONFIGURE_ARGS прописать только то, что надо.

Ссылка на сообщение
Ан9рей спасибо за помощь! Мне всё это очень интересно и вовсе не для того чтобы смотреть кино, техническая сторона всегда была на первом плане. Даст бог одолеем и ведро с оскамом и без sc :)

HDTV под Linux: Dreambox DM800 HD PVR имидж Nemesis V2.4 MgCamd 1.38+oscam+wicardd

Dreambox DM800 HD Pro (SIM 2.01)  Nemesis V2.3 MgCamd 1.38+oscam+wicardd
Omicom Skystar 4 Debian wheezy amd64 vdr+XBMC-PVR12+wicardd+oscam
Skystar USB HD :

Debian 7 wheezy TDE Trinity kaffeine-trinity 0.8.8 + sasc-ng

    KDE vdr+XBMC

Debian 8 Jessie  MythTV+ffdecsawrapper

Debian 9 Stretch vdr+oscam-emu + KODI
Dreambox 500 s  прошит под небесную шару
Satelite: 4.0W, 4,9E,13E, 36E, 75E, 85,1E, 90E
Русские дебианщики против цифрового слабоумия...

2c1e3141298276e3293ddac5449c0a44.png

Ссылка на сообщение

Ан9рей спасибо за помощь! Мне всё это очень интересно и вовсе не для того чтобы смотреть кино, техническая сторона всегда была на первом плане. Даст бог одолеем и ведро с оскамом и без sc :)

Не за что. Думаю, с OScam проблем возникнуть не должно, так как его не надо дорабатывать напильником, в отличие от vdr.
Ссылка на сообщение

кто может что посоветовать ,есть vdr 1.7.27 ubuntu 12.04 вывод через плагин xineliboutput происходит такое-при переключении на канал Триколор пропадает на какоето время звук если сразу перейти на другой канал и снова на этот то все нормально со звуком -пытался переставить драйвера dvb карты omicom ,ставил liplianin и 35 и 37 все то же самое повторяется,ставил vdr 1.7.31 так же без изменений ,Я так же наверное как и многие на форуме ,техническая сторона всегда была на первом плане

Ссылка на сообщение

Выложил я, наконец-то, свои сборки в ppa. Посему, приветствуются энтузиасты для тестирования.

Сейчас в ppa лежат такие пакеты:

vdr (с настройками и списком каналов для 36-го градуса, который должен работать сразу после установки)

vdr-plugin-xvdr

vdr-plugin-sc*

vdr-plugin-dvbapi

oscam

vdr-plugin-xvdr-picons (иконки каналов для 36-го градуса)

Устанавливаем так:

sudo apt-add-repository ppa:aap/vdr
sudo apt-get update

# purge установленные пакеты, не забывая сохранить конфиги
sudo apt-get purge vdr

# Ставим vdr + xvdr
sudo apt-get install vdr vdr-plugin-xvdr

# Иконки каналов
sudo apt-get install vdr-plugin-xvdr-picons-36e

# cardclient
sudo apt-get install vdr-plugin-sc-cardclient

# либо oscam вместо cardclient
sudo apt-get install vdr-plugin-dvbapi oscam

Настройка SC описана в шапке. С oscam может быть сложнее, но у меня все работает, если в /etc/oscam/oscam.server прописать свои настройки вместо <host>,<port> <user> <password>

Если у кого что-то не работает, либо есть предложения/пожелания - пишите, будем исправлять.

Ссылка на сообщение

Андрей! Пожелания есть! Хотелось бы видеть полностью оформленные deb-src для нормальных бэкпортов под debian testing или kanotix....я так и немогу переварить третьегном и по скольку второй гном доживает своё мигрирую на кеды...увы ubuntu заканчивает их полноценную поддержку.

HDTV под Linux: Dreambox DM800 HD PVR имидж Nemesis V2.4 MgCamd 1.38+oscam+wicardd

Dreambox DM800 HD Pro (SIM 2.01)  Nemesis V2.3 MgCamd 1.38+oscam+wicardd
Omicom Skystar 4 Debian wheezy amd64 vdr+XBMC-PVR12+wicardd+oscam
Skystar USB HD :

Debian 7 wheezy TDE Trinity kaffeine-trinity 0.8.8 + sasc-ng

    KDE vdr+XBMC

Debian 8 Jessie  MythTV+ffdecsawrapper

Debian 9 Stretch vdr+oscam-emu + KODI
Dreambox 500 s  прошит под небесную шару
Satelite: 4.0W, 4,9E,13E, 36E, 75E, 85,1E, 90E
Русские дебианщики против цифрового слабоумия...

2c1e3141298276e3293ddac5449c0a44.png

Ссылка на сообщение

Андрей! Пожелания есть! Хотелось бы видеть полностью оформленные deb-src для нормальных бэкпортов под debian testing или kanotix....я так и немогу переварить третьегном и по скольку второй гном доживает своё мигрирую на кеды...увы ubuntu заканчивает их полноценную поддержку.

Это вам не подходит для бэкпортов - deb-src http://ppa.launchpad.net/aap/vdr/ubuntu quantal main?

А чем вас не устраивает Убунту? У меня 2 системы с кедами. Одна - чистая убунту со снесенными нафиг юнити и гномом и с установленным кде из ppa:kubuntu-ppa/backports. Вторая - кубунту, но все кде пакеты из того же ppa. Конечно, жалко, что Каноникал прекращает поддержку кубунту, но я думаю, что, в ближайшем будущем, проект не умрет. Юнити, пока что, не конкурент кде (just imho).

Ссылка на сообщение

Если у кого что-то не работает, либо есть предложения/пожелания - пишите, будем исправлять.

Андрей. вдр ставится, плагины нет, не удовлетворяются зависимости.

Depends: vdr-plugin-sc (= 1.0.1+hg20120801~ppa3)

Как разрешить их?

Ссылка на сообщение

Андрей. вдр ставится, плагины нет, не удовлетворяются зависимости.

Depends: vdr-plugin-sc (= 1.0.1+hg20120801~ppa3)

Как разрешить их?

У вас, видимо, они из другого ppa ставятся (наверно, из fantom?). У меня нету sc с версией 1.0.1+hg20120801~ppa3: https://launchpad.net/~aap/+archive/vdr. Попробуйте отключить другие ppa.

Ссылка на сообщение

Попробуйте отключить другие ppa.

Конечно ламерский вопрос, но через гуи-синаптик вижу одни ппа, а в /etc/apt/sources.list

совсем другие, что-то изменили в 12.04? Если отключаю через гуи, а потом пробую заново

проинсталить по вашему ману чуть выше, то даже вдр не ставится

sudo apt-get install vdr vdr-plugin-xvdr
Reading package lists... Done
Building dependency tree	  
Reading state information... Done
E: Unable to locate package vdr-plugin-xvdr
Ссылка на сообщение

Конечно ламерский вопрос, но через гуи-синаптик вижу одни ппа, а в /etc/apt/sources.list

совсем другие, что-то изменили в 12.04? Если отключаю через гуи, а потом пробую заново

проинсталить по вашему ману чуть выше, то даже вдр не ставится

sudo apt-get install vdr vdr-plugin-xvdr
Reading package lists... Done
Building dependency tree	
Reading state information... Done
E: Unable to locate package vdr-plugin-xvdr

А вы, после удаления, добавили ppa и сделали update?

sudo apt-add-repository ppa:aap/vdr
sudo apt-get update

Кроме /etc/apt/sources.list надо еще смотреть и в /etc/apt/sources.list.d/.

Вот здесь есть полезный скриптик, который печатает все ppa - http://askubuntu.com/questions/148932/list-all-repositories-and-ppa-from-command-line

Удалить репозиторий можно командой sudo apt-add-repository -r <name>

И еще вопрос - какой у вас дистрибутив? В ppa есть сборка только для quantal.

Ссылка на сообщение

Хочется попробовать сборку Ан9рей vdr, но стоит ли переходить на 12.10 с 12.04? Есть ли какие-либо преимущества в плане использования xbmc и vdr? Планируется ли сборка для precise?

Ссылка на сообщение

И еще вопрос - какой у вас дистрибутив? В ppa есть сборка только для quantal.

да у меня тоже прицис. Чесно говоря, 27 страниц не осилил, поэтому начал читать с конца.

Тогда все понятно, почему не ставилось.

Ссылка на сообщение

Андрей, еще такой вопрос.

Дистрибутив у меня 12.04 и видео IntelHD.Насколько я понял xbmc для Интела есть репы только от Фантома.

Из мана уважаемого топикстартера становится понятно, что мне нужно ставить только его xbmc.

Установил, но при старте - корки

PVRDRIInitPVR2D: PVR2D device index (0)Running DIL (3.22.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
PVRDRIInitPVR2D: PVR2D device index (0)PVRDRIInitPVR2D: PVR2D device index (0)PVRDRIInitPVR2D: PVR2D device index (0)Segmentation fault (core dumped)
Crash report available at /home/roos/xbmc_crashlog-20121127_010332.log
в логе такое
[/size]
[size=4]........[/size]
01:03:31 T:8715712  NOTICE: GL_RENDERER = Gallium 0.4 on llvmpipe (LLVM 0x300)
01:03:31 T:8715712  NOTICE: GL_VERSION = 2.1 Mesa 8.0.4
01:03:31 T:8715712  NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20
01:03:31 T:8715712  NOTICE: GL_EXTENSIONS = GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D
......пртом очень много такой же ругани
похоже недонастроены иксы или xbmc ?
Ссылка на сообщение

Выложил я, наконец-то, свои сборки в ppa. Посему, приветствуются энтузиасты для тестирования.

Сейчас в ppa лежат такие пакеты:

vdr (с настройками и списком каналов для 36-го градуса, который должен работать сразу после установки)

vdr-plugin-xvdr

vdr-plugin-sc*

vdr-plugin-dvbapi

oscam

vdr-plugin-xvdr-picons (иконки каналов для 36-го градуса)

Устанавливаем так:

sudo apt-add-repository ppa:aap/vdr
sudo apt-get update

# purge установленные пакеты, не забывая сохранить конфиги
sudo apt-get purge vdr

# Ставим vdr + xvdr
sudo apt-get install vdr vdr-plugin-xvdr

# Иконки каналов
sudo apt-get install vdr-plugin-xvdr-picons-36e

# cardclient
sudo apt-get install vdr-plugin-sc-cardclient

# либо oscam вместо cardclient
sudo apt-get install vdr-plugin-dvbapi oscam

Настройка SC описана в шапке. С oscam может быть сложнее, но у меня все работает, если в /etc/oscam/oscam.server прописать свои настройки вместо <host>,<port> <user> <password>

Если у кого что-то не работает, либо есть предложения/пожелания - пишите, будем исправлять.

а можно и для XBMC добавили ppa, а то я решил попробовать Mint14 (ubuntu12.10), а xbmc не хочет собираться

Ссылка на сообщение

Андрей, еще такой вопрос.

Дистрибутив у меня 12.04 и видео IntelHD.Насколько я понял xbmc для Интела есть репы только от Фантома.

Из мана уважаемого топикстартера становится понятно, что мне нужно ставить только его xbmc.

Установил, но при старте - корки

PVRDRIInitPVR2D: PVR2D device index (0)Running DIL (3.22.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
PVRDRIInitPVR2D: PVR2D device index (0)PVRDRIInitPVR2D: PVR2D device index (0)PVRDRIInitPVR2D: PVR2D device index (0)Segmentation fault (core dumped)
Crash report available at /home/roos/xbmc_crashlog-20121127_010332.log
в логе такое
[/size]
[size=4]........[/size]
01:03:31 T:8715712 NOTICE: GL_RENDERER = Gallium 0.4 on llvmpipe (LLVM 0x300)
01:03:31 T:8715712 NOTICE: GL_VERSION = 2.1 Mesa 8.0.4
01:03:31 T:8715712 NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20
01:03:31 T:8715712 NOTICE: GL_EXTENSIONS = GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D
......пртом очень много такой же ругани
похоже недонастроены иксы или xbmc ?

Я не уверен, что сборка xvdr от Фантома будет работать с xvdr плагином из моего ppa из-за разных версий. Хотя у вас, судя по всему, до xvdr и не доходит, падает по какой-то другой причине.

У меня тоже интеловская графика, но XBMC я собираю из гита, своим скриптом, о котором писал выше:

git clone https://github.com/AndreyPavlenko/xbmc-build.git
cd xbmc-build

# Чтобы собрать только для интела

echo "VIDEO_DEPENDS='libva-dev'" > build.config
echo "CONFIGURE_ARGS='--enable-vaapi'" >> build.config

./build.sh

Если не пугает компиляция, то попробуйте собрать. Когда дойдут руки, выложу свою сборку XBMC + XVDR в ppa.

Ссылка на сообщение

а можно и для XBMC добавили ppa, а то я решил попробовать Mint14 (ubuntu12.10), а xbmc не хочет собираться

Добавлю, когда время появится. Не знаю как в Минт, но в ubuntu12.10 XBMC собирается еще проще, чем в 12.04.

Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
×
×
  • Создать...