В теме 196 сообщений

10 минут назад, Navigator сказал:

@Димон Пешеход

Вы бинарник и скрипт скопировали не в те папки ( наоборот сделали ). В папке /usr/script  у вас лежит скрипт для mgcamd ?

Сорри, не так немного (не на ту строку посмотрел)

wicard.emu в /usr/script

wicardd-mipsel в /usr/bin

wicard.conf в /etc/tuxbox/config

В  /usr/script сейчас есть файлы

wicard.emu

Delete_All_Crashlogs

Ifconfig

Netstat

Uptime

Изменено пользователем Димон Пешеход
дополнил ответ

Поделиться сообщением


Ссылка на сообщение
6 минут назад, Navigator сказал:

@Димон Пешеход

Посмотрите скрипт для mgcamd  еще в папках /etc  и  /etc/init.d

Если можно, то расшифруйте "скрипт". Редко ковыряю дрима, посему не все улавливаю. Ищем файлы с именем mgcamd  в указанных вами папках?

В папке /etc/tuxbox/config есть файл newcamd.conf

Более следов не вижу

Изменено пользователем Димон Пешеход
добавил ответ

Поделиться сообщением


Ссылка на сообщение

@Димон Пешеход

Да, в имени файла будет присутствовать mgcamd, еще посмотрите в папке/usr  должна быть папка camscript

Поделиться сообщением


Ссылка на сообщение
5 минут назад, Navigator сказал:

@Димон Пешеход

Да, в имени файла будет присутствовать mgcamd, еще посмотрите в папке/usr  должна быть папка camscript

Есть такая папка, в ней два файла:

Ncam_Ci

Ncam_mgcamd_1.31

Поделиться сообщением


Ссылка на сообщение

@Димон Пешеход

Расширение у файлов .sh ? И покажите содержимое файла

4 минуты назад, Димон Пешеход сказал:

Ncam_mgcamd_1.31

 

Поделиться сообщением


Ссылка на сообщение
2 минуты назад, Navigator сказал:

@Димон Пешеход

Расширение у файлов .sh ? И покажите содержимое файла

 

Да, расширение .sh

#!/bin/sh

CAMNAME="Mgcamd-1.31"

remove_tmp () {
    rm -rf /tmp/*.info* /tmp/*.tmp* /tmp/*mgcamd*
}

case "$1" in
    start)
    echo "[SCRIPT] $1: $CAMNAME"
    remove_tmp
    /usr/bin/mgcamd_1.31 &
    ;;
    stop)
    echo "[SCRIPT] $1: $CAMNAME"
    killall -9 mgcamd_1.31
    remove_tmp
    ;;
    *)
    $0 stop
    exit 0
    ;;
esac

exit 0 

Поделиться сообщением


Ссылка на сообщение

Создайте в этой папке файл  Ncam_wicard.sh  с содержимым

Цитата

 

#!/bin/sh

CAMNAME="Wicard"

remove_tmp () {
    rm -rf /tmp/*.info* /tmp/*.tmp* /tmp/*wicardd*
}

case "$1" in
    start)
    echo "[SCRIPT] $1: $CAMNAME"
    remove_tmp
    /usr/bin/wicardd-mipsel -d -c /etc/tuxbox/config/wicardd.conf &
    ;;
    stop)
    echo "[SCRIPT] $1: $CAMNAME"
    killall -9 wicardd-mipsel
    remove_tmp
    ;;
    *)
    $0 stop
    exit 0
    ;;
esac

exit 0

 

 

Атрибуты на файле измените на 755, перегрузите ресивер и пробуйте

Поделиться сообщением


Ссылка на сообщение

Wicard появился. Запускаю, но картинка не декодируется (настройки конфига залил сразу, еще до обращения за помощью)

Поделиться сообщением


Ссылка на сообщение

Что то не получается прослушать TraySyslog лог работы. У меня порт указан другой (не 514). Пробовал и 514 порт и другой

Поделиться сообщением


Ссылка на сообщение

@Димон Пешеход

Телнетом снимайте, это самый верный способ

PS.  Уточните еще точное название конфига и путь к нему, по какому вы файл скопировали в ресивер. Это важно

Поделиться сообщением


Ссылка на сообщение
30 минут назад, Navigator сказал:

@Димон Пешеход

Телнетом снимайте, это самый верный способ

PS.  Уточните еще точное название конфига и путь к нему, по какому вы файл скопировали в ресивер. Это важно

после ввода root выходит странное сообщение:

OpenDreambox 1.5.0 dm800

dm800 login: root
root@dm800:~#

Если ввести пароль dreambox то пишет:


OpenDreambox 1.5.0 dm800

dm800 login: root
root@dm800:~# dreambox
-sh: dreambox: not found
root@dm800:~#

Поделиться сообщением


Ссылка на сообщение

@Димон Пешеход

Вы уже авторизовались, пароль не нужен в вашем случае, он не установлен. Смотрите процессы, киляйте викард, если он есть в процессах и стартуйте, только подправьте конфиг, как указано в описании

Поделиться сообщением


Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти

  • Похожий контент

    • От Kirigor
      Ресивер Skyway Nano 3, прошивка последняя: v3.02.60 
      Плагин Wicard 1.18.
      Проблема: сообщение "Канал закодирован" после того, как в течении кого-то времени (около 8 часов) не переключались каналы.
      Лечится переключением на другой канал или перезагрузкой. 
      Не знаю точно когда появился такой баг, но раньше точно таких проблем не было.
      Вот небольшой лог, снятый программой Wicard Logger в момент когда канал закодирован и после переключения на другой канал:
      20:49:15 192.168.1.111 DVB0[STAPI]: ECM81 (0500:060C00/4E89.0) 'HTB+:Pervyy kanal HD' not decoded by ntv+custom
      20:49:25 192.168.1.111 DVB0[STAPI]: ECM80 (0500:060C00/4E89.0) 'HTB+:Pervyy kanal HD' not decoded by ntv+custom
      20:52:04 192.168.1.111 DVB0[STAPI]: ECM81 (0500:060C00/4E8A.0) 'HTB+:Rossiya HD' not decoded by ntv+custom
      20:52:04 192.168.1.111 DVB0[STAPI]: ECM81 (0500:060A00/4E8A.0) 'HTB+:Rossiya HD' decoded by ntv+custom
      20:52:06 192.168.1.111 DVB0[STAPI]: ECM80 (0500:060A00/4E8A.0) 'HTB+:Rossiya HD' decoded by ntv+custom
       
    • От dunaev_d
      После того как на GI8120 накрылся один загрузчик (Spark), установил на второй, E2 и имидж OPenATV 5.0, потом поставил wicardd 1.19 с фида но он отказывается стартовать. Т.е. захожу в SoftCamPanel - выбираю Cam1=Wicard 1.19 - жму старт, но он не запускается. Пробовал тем же способом ставить MgCamd - тоже самое.Так же пробовал ставить вручную через папку /temp ресивера вот этот http://gomel-sat.bz/files/file/861-wicardd-119/ - такая же история. Подскажите из за чего это может быть, почему эмуляторы не запускаются?
      P.S. После установки атрибуты у файла Wicardd в папке  var/bin  755 выставлял.
    • От satus
      Wicard с конфигом для Openbox SX серии, Skyway Classic 4, Skyway Nano 3, Skyway Light 2
      Описание установки данного эмулятора здесь.
    • От okulist
      Добрый вечер. Не работает первый +2. Это что то изменилось?