дядя Фёдор

Аддон эмуляторов для PGI

В теме 270 сообщений

что такое аддон и для чего он нужен.? я новичёк не обижайтесь на глупый вопрос. если можно дайте ссылку почитать.

Аддон - надстройка к основной программе / софту. Применяется для расширения возмодностей системы.

Про него читай тут.но с первой страницы.

Поделиться сообщением


Ссылка на сообщение

Обновлен аддон, линк на первой странице.

Последние версии oscam, mgcamd и драйвера картоприемника с фиксом для карт Ориона.

Как удалить старый ?

Поделиться сообщением


Ссылка на сообщение

Как удалить старый ?

Просто поставить новый сверху (при условии, что вы не меняли вручную скрипты из нынешнего аддона).

Файлы конфигурации эмуляторов должны остаться нетронутыми.

Поделиться сообщением


Ссылка на сообщение

Подскажите, пожалуйста Xcam или Oscam (с протоколом NewCamd 5.25 ) - как прикрутить к PGI 1.2?

Поделиться сообщением


Ссылка на сообщение

Подскажите, пожалуйста Xcam или Oscam (с протоколом NewCamd 5.25 ) - как прикрутить к PGI 1.2?

Xcam не знаем. По oscam есть отдельная тема.

И что там прикручивать? OSCAM уже есть в аддоне, настроить только нужно правильно.

Поделиться сообщением


Ссылка на сообщение

Требует новую версию библиотек.

/var/bin/oscam: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

compiled at 08/17/11 20:42:50 by bhishma@Waterhouse

ioctl failed.(Invalid argument)

В наличии libcrypto.so.0.9.8

Тогда подождите PGI 1.3... осталось совсем недолго.

Либо добавьте линк на libcrypto.so.1.0.0 через libcrypto.so.0.9.8

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

Обновлен аддон (фиксы oscam и драйвера картоприемника).

Обновлены ссылки в первом посте.

Поделиться сообщением


Ссылка на сообщение

Проблема разблокировки каналов пакета XtraTV @ Amos 4W с помощью newcamd. На форумах пишут, что нужна какая-то версия newcamd "а", адаптированный под этот пакет. У вас не будет такого, чтобы установить как плагин?

Пока что приходится переключаться на на oscam для просмотра этого пакета, что требует изменения типа эмулятора через веб-интерфейс и перегрузки ресивера.

Поделиться сообщением


Ссылка на сообщение

ребята, кто-нибудь знает как сделать запись по двум логинам? т.е. есть два логина, на одном смотреть, на другом записывать

Поделиться сообщением


Ссылка на сообщение

делай через мглаунхер (специальная версия мгкамд), там можно три логина прописать: один для просмотра, один для записи и один для пип

Поделиться сообщением


Ссылка на сообщение

а есть где почитать про это? заранее спасибо!

Поделиться сообщением


Ссылка на сообщение

настроил mg_launcher, но в логах не видно второго логина, настраивал через web интерфейс..... или так и должно быть?

Поделиться сообщением


Ссылка на сообщение

настроил mg_launcher, но в логах не видно второго логина, настраивал через web интерфейс..... или так и должно быть?

а в ньюкамдлистов у тебя сколько?

Изображение

Поделиться сообщением


Ссылка на сообщение

в ньюкам листе 1. - один логин

2. - второй логин

3. - третий логин

может надо включить запрет двойных запросов, или версию мджикамд понизить? стоит 1.38

Поделиться сообщением


Ссылка на сообщение

может надо включить запрет двойных запросов, или версию мджикамд понизить? стоит 1.38

Запрет точно не нужно включать, точнее его точно нужно выключить.

Проблема может быть в другом. В прошивках PGI, где-то с версии 1.0, может 1.1 была переделана вся система которая распределяет потоки данных на каналы декодирования.

Это было сделано для того, чтобы стали возможными такие вещи, как просмотр PiP и одновременный видео выход на HDMI и компонент.

Потом последовали модификации для возможности просмотра и записи двух каналов с одного транспондера, и т.д.

В общем, на сегодняшний день, получается то, что mgcamd (как и должен изначально), работает с пятью (вместо как раньше с тремя) потоками данных.

Предсказать в какой из пяти пойдет нужный поток почти невозможно, потому что зависит от количества тюнеров, от того, включен ли таймшифт, записывается ли с одного и того же транспондера, от того, в какой последовательности была запись, PiP или переключение каналов последний раз, и т.д. То, есть распределение потоков - динамическое.

Поэтому, теперь невозможно точно сказать, будет работать mg_launcher так, как надо или нет, потому что он работает только с тремя потоками, а не с пятью.

Нужно экспериментировать и смотреть логи mgcamd - он там пишет, какой из пяти потоков сейчас декодируется.

Если повезет - то будет как надо работать, а если нет - ничего не поделать.

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

Подскажите, ГУРУ. не могу заставить mgcamd запускаться после reboot рессивера. в web-интерфейсе ставил Card Server: None и NewCS, Softcam: mgcamd. сохранялся. перезапускал аппарат. не грузится эмулятор автоматом при старте рессивера, только после нажатия желтой кнопки запускается. куда копать?

Изменено пользователем Driverz

Поделиться сообщением


Ссылка на сообщение

Подскажите, ГУРУ. не могу заставить mgcamd запускаться после reboot рессивера. в web-интерфейсе ставил Card Server: None и NewCS, Softcam: mgcamd. сохранялся. перезапускал аппарат. не грузится эмулятор автоматом при старте рессивера, только после нажатия желтой кнопки запускается. куда копать?

В сторону логов начальной загрузки.

Но вообще-то я бы проверил, действительно ли есть файлы в /var/bin/init.d и какие у них атрибуты.

Поделиться сообщением


Ссылка на сообщение

Стал зависать IPBox91HD под PGI1.3. Грешил на шару, отключил все, даже сетевой кабель вынул - все равно виснет. Не реагирует на пульт, только кнопка PWR+OK помогает. Не зависит от канала который просматривается в данный момент. Базу сбрасывал и закачивал заново. Не могу ни с чем скореллировать, может кто нить помочь? Может лог какой нибудь записать можно?

Эмпирическим путем выяснил что виноват addon-v009.pgi.tbz2. C версией addon.007.pgi.tbz2 не виснет, и работает стабильно.

Поделиться сообщением


Ссылка на сообщение

Эмпирическим путем выяснил что виноват addon-v009.pgi.tbz2. C версией addon.007.pgi.tbz2 не виснет, и работает стабильно.

актуальная на сегодня версия - 011.

есть на уплоуде форума.

Поделиться сообщением


Ссылка на сообщение

В сторону логов начальной загрузки.

Но вообще-то я бы проверил, действительно ли есть файлы в /var/bin/init.d и какие у них атрибуты.

есть start.cs, start.dyndns, start.ethaddr, start.something, start.streamts, stop.something.

у всех аттрибуты -rwxr-xr-x

Изменено пользователем Driverz

Поделиться сообщением


Ссылка на сообщение

есть start.cs, start.dyndns, start.ethaddr, start.something, start.streamts, stop.something.

у всех аттрибуты -rwxr-xr-x

Тогда поставьте DEBUG=yes в pgi.conf и посмотрите после перезагрузки /var/log/cs.log

Поделиться сообщением


Ссылка на сообщение

очень интересно. после смены встроенного харда. всё заработало. предыдущий хард время от времени отваливался. возможно в этом была проблема. пока полёт нормальный.

Поделиться сообщением


Ссылка на сообщение

актуальная на сегодня версия - 011.

есть на уплоуде форума.

C ней тоже виснет. Откатился на 007.

Поделиться сообщением


Ссылка на сообщение

Хелп !Засада.

Прошился на новую прошивку, скачал аддон, прописал код с биллинга в /var/keys/newcamdlist

и смотрю черный квадрат малевича. Что может быть и как бороться ?

Поделиться сообщением


Ссылка на сообщение

Хелп !Засада.

Прошился на новую прошивку, скачал аддон, прописал код с биллинга в /var/keys/newcamdlist

и смотрю черный квадрат малевича. Что может быть и как бороться ?

проверь тип ресивера в mg_cfg

PS

В вэб-фэйсе посмотри какой эму выбран...

Изображение

Изменено пользователем ProFanas

Поделиться сообщением


Ссылка на сообщение

Принесли ресивер 91HD. В нем прошивка 0.7.3.

Поставил последний addon 011 версия.

В закладке CS выбираю CardServer: None и SoftCam: mgcamd, сохраняю, перегружаю ресивер.

Для проверки даю команду ps afx | grep mgcamd | grep -v grep в ответ появляется чистая строка и все.

Addon переустанавливал, не помогло.

В чем может быть дело?

Как проверить работает mgcamd или нет?

Поделиться сообщением


Ссылка на сообщение

Принесли ресивер 91HD. В нем прошивка 0.7.3.

Поставил последний addon 011 версия.

В закладке CS выбираю CardServer: None и SoftCam: mgcamd, сохраняю, перегружаю ресивер.

Для проверки даю команду ps afx | grep mgcamd | grep -v grep в ответ появляется чистая строка и все.

Addon переустанавливал, не помогло.

В чем может быть дело?

Как проверить работает mgcamd или нет?

Для того чтобы стартовал mgcamd нужно чтобы был включен канал. Включите любой канал, даже открытый, и тогда смотрите будет стартовать mgcamd или нет.

Если нет, то вот это: http://gomel-sat.bz/forums/index.php?s=&a...st&p=469162

Поделиться сообщением


Ссылка на сообщение

Уважаемые форумчане!!!

Уже два дня бьюсь и никак немогу победить.

Не стартует никак mgcamd автоматом при старте ресивера.

Перепродовал прошивки с 0.7.3 и до 1.3

Ставлю прошивку, сброс на заводские настройки, перезагрузка.

Ставлю addon-011, появляется пункт CS, выбираю CardServer: none SoftCam: mgcamd сохраняю, перезагрузка.

Не стартует эмуль.

Назначил на зеленую кнопку рестарт эмулятора, нажимаем ее после загрузки и только тогда, стартует эмулятор.

Включил debug в Pgi.conf, лог прилагается.

Последняя строчка, после нажатия на зеленую кнопку появляется.

Что можно сделать с этим или где ошибся? :wacko: :blink:

[main] [00:55:24] started
+ DIR_DB=/var
+ DIR_TMP=/tmp
+ DIR_MNT=/mnt
+ DIR_USB=/mnt/usb
+ DIR_HDD=/mnt/hdd
+ DIR_NFS=/mnt/nfs
+ DIR_PLUGIN=/var/plug-in
+ DEF_SKIN=/usr/share/sbox/image/dark
+ DIR_PICONS=/var/picons
+ EPG_DATA_DIR=/media
+ SKIN=default
+ TIMEOUT_WAIT_FOR_SKIN=30
+ /usr/bin/tvmode
+ TVOUT=1920x1080-50i
+ log setting tv mode: [1920x1080-50icvbs]
+ date +%H:%M:%S
+ echo [main] [00:55:24] setting tv mode: [1920x1080-50icvbs]
[main] [00:55:24] setting tv mode: [1920x1080-50icvbs]
+ echo default
+ awk /^\/(media|hdd)\//{print}
+ [ -n  ]
+ echo default
+ awk /^\/mnt\/usb/{print}
+ [ -n  ]
+ front_ioctl --job puts LOADING
+ log user set skin: [default]
+ date +%H:%M:%S
+ echo [main] [00:55:25] user set skin: [default]
[main] [00:55:25] user set skin: [default]
+ [ default = default ]
+ basename /usr/share/sbox/image/dark
+ SKIN_NAME=dark
+ dirname /usr/share/sbox/image/dark
+ DIR_PIECE=/usr/share/sbox/image
+ log actual skin: [/usr/share/sbox/image/dark]
+ date +%H:%M:%S
+ echo [main] [00:55:25] actual skin: [/usr/share/sbox/image/dark]
[main] [00:55:25] actual skin: [/usr/share/sbox/image/dark]
+ echo /media
+ awk {gsub(/[^a-z_A-Z0-9\-\/\.]/,"");print}
+ DIR_EPG=/media
+ log EPG database path is [/media]
+ date +%H:%M:%S
+ echo [main] [00:55:25] EPG database path is [/media]
[main] [00:55:25] EPG database path is [/media]
+ ARG_SBOX=
+ [ ! -f /tmp/pgi_net_ready ]
+ sleep 1
+ [ ! -f /tmp/pgi_net_ready ]
+ sleep 1
+ [ ! -f /tmp/pgi_net_ready ]
+ sleep 1
+ [ ! -f /tmp/pgi_net_ready ]
+ sleep 1
+ [ ! -f /tmp/pgi_net_ready ]
+ sleep 1
+ [ ! -f /tmp/pgi_net_ready ]
+ [ ! -d /dev/stapi ]
+ ls -ld /dev/stapi
+ awk {print $5}
+ [ 500 -ne 500 ]
+ expr /dev/sda2 : /dev/sd[a-z][1-9]$
+ [ -d /sys/block/sda ]
+ [ ! -d /sys/block/sda ]
+ [ auto = force ]
+ [ -n  ]
+ log HDD is not detected and no NFS requested, disabling HDD support
+ date +%H:%M:%S
+ echo [main] [00:55:30] HDD is not detected and no NFS requested, disabling HDD support
[main] [00:55:30] HDD is not detected and no NFS requested, disabling HDD support
+ ARG_SBOX=
+ log starting sbox application
+ date +%H:%M:%S
+ echo [main] [00:55:30] starting sbox application
[main] [00:55:30] starting sbox application
+ cd /usr/bin
+ ./sbox 
ioctl failed.(Invalid argument)
> Starting mgcamd...done!

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

какой бокстип у тебя в mg_cfg?

у меня так:

Изображение

Безотказный стартна всех вариантах прошивок.

Изменено пользователем ProFanas

Поделиться сообщением


Ссылка на сообщение

C ней тоже виснет. Откатился на 007.

У меня с 007 всё равно виснет. Не пойму в чём дело, то ли в PGI 1,3 то ли в Oscame...Использую Cuberevo 250HD с офф. картой триколора 24-серии.

Поделиться сообщением


Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти