дядя Фёдор

Wi-Fi на на прошивках PGI

В теме 570 сообщений

к стати тут стоит чип RT2571 MF

ревизия H/W Ver:A1 F/W Ver.: 1.30

Не ужели придется брать DWA-125 ?

вот интересно! везде расписано четко, что драйверы для чипов 28... и 30....

а Вы так искренне удивляетесь, чего это 25.... не работает?

хотите, чтобы работало сегодня - берите, то что проверено.

а будущее - ну так на то оно и будущее, что никто не знает что в нем.

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

Сегодня приобрел в Wi-Fi адаптер не глядя, можно сказать. Спросил у консультанта на какком чипсете устройство? В ответ на чипе Ralink. В итоге получил вот это - "Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter" Имею два девайса DWA 110 и Acorp USB WUD-G (802.11g) и оба не работают пока))))

Поделиться сообщением


Ссылка на сообщение

Не стал мучится приобрел DWA-125. но не как не могу подружить его с DIR-320.

логи.

[PGI ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 RT3070 Wireless ESSID:""

Mode:Auto Frequency=2.412 GHz Bit Rate:1 Mb/s

Encryption key:off

Link Quality=10/100 Signal level:0 dBm Noise level:-115 dBm

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

изменяю соответственно в папке /var/etc/Wireless/RT3070STA/rt3070sta.dat

SSID=Krannik

NetworkType=Infra

WirelessMode=9

Channel=9

BeaconPeriod=100

TxPower=100

BGProtection=0

TxPreamble=0

RTSThreshold=2347

FragThreshold=2346

TxBurst=1

PktAggregate=0

WmmCapable=1

AckPolicy=0;0;0;0

AuthMode=WPAPSK

EncrypType=TKIP

WPAPSK=krannikkrannik

ну не хочет вязаться

[PGI ~]$ ipaddr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

inet 127.0.0.1/8 scope host lo

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000

link/ether 00:13:18:02:4e:5d brd ff:ff:ff:ff:ff:ff

inet 192.168.1.5/28 brd 192.168.1.15 scope global eth0

3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000

link/ether 00:26:5a:17:49:44 brd ff:ff:ff:ff:ff:ff

[PGI ~]$

wlan0 Link encap:Ethernet HWaddr 00:26:5A:17:49:44

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Поделиться сообщением


Ссылка на сообщение

попробовал прописать статичный апи ругается на

iface wlan0 inet static

address 192.168.1.10

netmask 255.255.255.240

gateway 192.168.1.1

[PGI ~]$ ifup -i /var/interfaces_wlan wlan0

"fup: unknown method "static

[PGI ~]$

помогите что не так

Поделиться сообщением


Ссылка на сообщение

помогите что не так

попробуй

netmask 255.255.255.0

WirelessMode=5

iface wlan0 inet dhcp - не работает.

Изменено пользователем VadimI

Поделиться сообщением


Ссылка на сообщение

помогите что не так

не так EncrypType=TKIP

надо вот так EncrypType=AES

и в DIR-320 тоже AES

Поделиться сообщением


Ссылка на сообщение

Подтверждаю работоспособность TP-link TL-WN727N Ver: 1.3 (RT3070)

Запустил на WPA-PSK TKIP со статическим IP.

Поделиться сообщением


Ссылка на сообщение

Шаманские методы подошли :rolleyes:

проблема в том что редактировал в WinSCP из за этого были косяки перелапатил все в FAR-е все поднялось действительно DHCP не работает статик апи поднялось все

Поделиться сообщением


Ссылка на сообщение

Выложите, плиз, кто-нибудь сырой файлик RT3070.dat, а то я своё подтёр маленько. Спасибо!

Поделиться сообщением


Ссылка на сообщение

Простите, не подскажите заработает ли ASUS USB N11

Заранее благодарю за ответ.

Поделиться сообщением


Ссылка на сообщение

Простите, не подскажите заработает ли ASUS USB N11

Заранее благодарю за ответ.

Судя по ссылке на Linux драйвера на сайте Asus, он на RT2870, т.е. должон заработать.

Поделиться сообщением


Ссылка на сообщение

Выложите, плиз, кто-нибудь сырой файлик RT3070.dat, а то я своё подтёр маленько. Спасибо!

Защищённая от записи копия должна быть на Вашем ресивере тут:

/etc/Wireless/RT3070STA.dat

Поделиться сообщением


Ссылка на сообщение

Как я понял не кто помочь мне не может ?

или не хочет ?

Поделиться сообщением


Ссылка на сообщение

Как я понял не кто помочь мне не может ?

или не хочет ?

А мы по твоему чем занимаемся, но ты не удосужился отписаться об использовании предложеных настроек!

Пробовал?

iface wlan0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1

Пробовал?

WirelessMode=5

Настройки WIFi роутера (ВСЕ, включая дополнительные) в студию!

Поделиться сообщением


Ссылка на сообщение

У меня так заработало , Настройки AP ==> Authentication Type Open System

802.11g Protection ==> Disabled

Encryption : WEP , Key Length : 64-bit

Channel Number : 11

Adapter DWA 125

#The word of "Default" must not be removed
Default
CountryRegion=5
CountryRegionABand=7
CountryCode=
ChannelGeography=1
SSID=MyWlan
NetworkType=Infra
WirelessMode=5
Channel=0
BeaconPeriod=100
TxPower=100
BGProtection=0
TxPreamble=0
RTSThreshold=2347
FragThreshold=2346
TxBurst=1
PktAggregate=0
WmmCapable=1
AckPolicy=0;0;0;0
AuthMode=OPEN
EncrypType=WEP
WPAPSK=
DefaultKeyID=1
Key1Type=
Key1Str=712*******
Key2Type=1
Key2Str=
Key3Type=1
Key3Str=
Key4Type=1
Key4Str=
PSMode=CAM
AutoRoaming=0
RoamThreshold=70
APSDCapable=0
APSDAC=0;0;0;0
HT_RDG=1
HT_EXTCHA=0
HT_OpMode=1
HT_MpduDensity=4
HT_BW=1
HT_BADecline=0
HT_AutoBA=1
HT_BADecline=0
HT_AMSDU=0
HT_BAWinSize=64
HT_GI=1
HT_MCS=33
HT_MIMOPSMode=3
HT_DisallowTKIP=1
EthConvertMode=
EthCloneMac=
IEEE80211H=0
TGnWifiTest=0
WirelessEvent=0
MeshId=MESH
MeshAutoLink=1
MeshAuthMode=OPEN
MeshEncrypType=NONE
MeshWPAKEY=
MeshDefaultkey=1
MeshWEPKEY=
CarrierDetect=0
AntDiversity=0
BeaconLostTime=4
FtSupport=1
Wapiifname=ra0
WapiPsk=
WapiPskType=
WapiUserCertPath=
WapiAsCertPath=

Здесь ./var/interfaces_wlan прописал статический адрес, маску и.т.д

Все работает!!! Спасибо Вам дядя Федор and Pacco

Поделиться сообщением


Ссылка на сообщение

Судя по ссылке на Linux драйвера на сайте Asus, он на RT2870, т.е. должон заработать.

Благодарю...

Поделиться сообщением


Ссылка на сообщение

А мы по твоему чем занимаемся, но ты не удосужился отписаться об использовании предложеных настроек!

Пробовал?

iface wlan0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1

Пробовал?

WirelessMode=5

Настройки WIFi роутера (ВСЕ, включая дополнительные) в студию!

на первое зачем я должен делать

address 192.168.1.10

netmask 255.255.255.0 почему вся сеть если у меня на роутере не открыта вся сеть а только часть адресов скрин прилагаю у меня настройка 255.255.255.240

gateway 192.168.1.1

WirelessMode=5
пробы вал не помогает

далее скрины роутера включая дополнительные (как понял ваерлеса )

post-55204-1270491947_thumb.png

post-55204-1270491934_thumb.jpg

post-55204-1270491961_thumb.jpg

post-55204-1270492094_thumb.jpg

post-55204-1270492116_thumb.jpg

post-55204-1270492154_thumb.jpg

Поделиться сообщением


Ссылка на сообщение

зачем я должен делать

netmask 255.255.255.0 почему вся сеть если у меня на роутере не открыта вся сеть а только часть адресов скрин прилагаю у меня настройка 255.255.255.240

Ты будешь "пробЫ вать" или спорить!? :angry:

Выставь маску и в роутере и в конфиге 255.255.255.0

Не заработает - вернешь назад.

#The word of "Default" must not be removedDefaultCountryRegion=5CountryRegionABand=7CountryCode=ChannelGeography=1SSID=KrannikNetworkType=InfraWirelessMode=9  #или 5Channel=9BeaconPeriod=100TxPower=100BGProtection=0TxPreamble=0RTSThreshold=2347FragThreshold=2346TxBurst=1PktAggregate=0WmmCapable=1AckPolicy=0;0;0;0AuthMode=WPAPSKEncrypType=AESWPAPSK=yooryourkeykeDefaultKeyID=1Key1Type=1Key1Str=Key2Type=1Key2Str=Key3Type=1Key3Str=Key4Type=1Key4Str=.....
Какие варианты в параметре "Regulatory Mode"?

Wireless mode - попробуй принудительно выставить "G".

Канал попробуй смени с 9-го на 6-й и в роутере и в конфиге.

И скрины лишние удали из первого поста, нужен первый и предпоследний.

Поделиться сообщением


Ссылка на сообщение

Ув.Дядя Фёдор

У меня D-link DWA-125 A2

[PGI ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

и всё!

Посоветуйте,что делать.

Поделиться сообщением


Ссылка на сообщение

Ув.Дядя Фёдор

У меня D-link DWA-125 A2

[PGI ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

и всё!

Посоветуйте,что делать.

Менять на

Dlink DWA-125 A1

Dlink DWA-140 B1, В2

Или еще что-то заработавшее из этой ветки.

Или ждать дров.

В DWA-125 A2 - какая-то модификация чипсета - DRT2870...расковыряй, посмотри, он легко разбирается.

Изменено пользователем VadimI

Поделиться сообщением


Ссылка на сообщение

Ув.Дядя Фёдор

У меня D-link DWA-125 A2

[PGI ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

и всё!

Посоветуйте,что делать.

покажите что выдает команда lsusb (исполнять команду не через веб интерфейс, а через Telnet)

В DWA-125 A2 - какая-то модификация чипсета - DRT2870...расковыряй, посмотри, он легко разбирается.

Если бы там была модификация именно этого чипсета, то работало бы нормально. Думаю, там совсем другой чипсет.

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

[PGI ~]$ lsusb

Bus 002 Device 001: ID 0000:0000

Bus 001 Device 002: ID 07d1:3c16 D-Link System

Bus 001 Device 001: ID 0000:0000

чипсет RT3070L

Поделиться сообщением


Ссылка на сообщение

Если бы там была модификация именно этого чипсета, то работало бы нормально. Думаю, там совсем другой чипсет.

Возможно.

Повторно прошу хозяина разобрать адаптер.

Разбиратся вводом ногтя в щели между половинками корпуса у разъема.

Товарный вид не портится!

[PGI ~]$ lsusb

чипсет RT3070L

Ето выдалось по lsusb?

Если там действительно RT3070 - то должен работать.

Изменено пользователем VadimI

Поделиться сообщением


Ссылка на сообщение

Ето выдалось по lsusb?

Если там действительно RT3070 - то должен работать.

Нет.Это я разобрал устройство

Поделиться сообщением


Ссылка на сообщение

Нет.Это я разобрал устройство

Спасибо! :rolleyes:

Ну так должно работать!

Правь файл RT3070STA.DAT в соответствии с настройками своего роутера (AP).

Исправь под свою сеть файл /var/interfaces_wlan:

iface wlan0 inet static
  address 192.168.1.10
  netmask 255.255.255.0
  gateway 192.168.1.1

Перегрузи ресивер с воткнутым адаптером, а потом iwconfig.

Изменено пользователем VadimI

Поделиться сообщением


Ссылка на сообщение

Дядя Фёдор, внесите в список совместимых девайсов TP-link TL-WN727N Ver: 1.3 (RT3070). Двое суток отработал без проблем!

Поделиться сообщением


Ссылка на сообщение

RT3070.dat отредактировал, /var/interfaces_wlan тоже,но всё равно

[PGI ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

и всё!

Советы,пожелания?

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

RT3070.dat отредактировал, /var/interfaces_wlan тоже,но всё равно

[PGI ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

и всё!

Советы,пожелания?

Идентификатора вашего устройства нет в драйвере сейчас. Добавим его когда будет бета PGI 0.7.

Дядя Фёдор, внесите в список совместимых девайсов TP-link TL-WN727N Ver: 1.3 (RT3070). Двое суток отработал без проблем!

Спасибо!

Изменено пользователем дядя Фёдор

Поделиться сообщением


Ссылка на сообщение

Ты будешь "пробЫ вать" или спорить!? :angry:

Выставь маску и в роутере и в конфиге 255.255.255.0

Не заработает - вернешь назад.

Прописал как вы сказали еще поставил

AuthMode=OPEN

EncrypType=NONE

коннект прошол и вафля заработала.

Дальше буду пробывать шифровать вафлю.

странно но все заработало

Спасибо

Поделиться сообщением


Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти