дядя Фёдор

Wi-Fi на на прошивках PGI

В теме 570 сообщений

Когда инет статический, то получаю вот такое:

 
[PGI ~]$ ifup -i /var/interfaces_wlan wlan0
ip: RTNETLINK answers: File exists
[PGI ~]$ 

Поделиться сообщением


Ссылка на сообщение

Залезь в вэб-интерфейс, выстави нужные параметры и..

LAN отключится, а Wi-Fi заработает (возможно)

 

 

6Z0g7C.png

Поделиться сообщением


Ссылка на сообщение

Чуда не случилось и применение настроек через вебинтерфейс не помогло. Вывод - драйвер не поддерживает ни один из тех чипов, что стоят у меня в имеющихся свистках.

Но я не сдался, а нашёл в инете и заказал Edimax EW-7711UAn. Вчера он пришёл, я его воткнул, подключился, поднял интерфейс, проверил разными командами и уже начал радоваться, что телнет писал правильные ответы. Перегрузил рес и кино пошло! Ура! Спасибо Дяде Фёдору, Профанасу и другим гуру, что всё это придумали и описали.

Но...

Без "но", в сожалению, не обошлось. Смотреть кино нельзя, постоянно идут остановы и "канал заблокирован или недоступен". Потом либо само начинается, либо после жёлтой кнопки. Почему-то или забывает через свисток отправить коды или делает это с опозданием. Хотя другой мой рес (Sezam-1000HD), работающий также через вай-фай, таких проблем не доставляет.

Подскажите, пожалуйста, данная проблема как-то лечится? Может в каком-нить файле дописать чего надо?! Заранее благодарю.

Поделиться сообщением


Ссылка на сообщение

попробуй свистку статику предложить, ну и роутер можно пошевелить на предмет сопряжения со свистком...

 

а так же мг.конфиг покурить. или его от второгог реса попробовать.

Поделиться сообщением


Ссылка на сообщение

@ProFanas,

У меня и так он на статике. Я когда писал прошлые посты с dhcp было только для настройки, а сейчас всё со статикой и под жёсткими паролями)))

А вот за подсказку как можно роутер пошевелить на предмет сопряжения со свстком, буду очень благодарен, хотя в этом случае не понятно как роутер нормально дружит со свистками других ресов, хотя как-либо дополнительно они не сопрягались и не шевелились.

И что можно с мг.конфиг сделать и где он ваще? Его точно есть смысл на других ресах искать - они ведь у меня на Е2?!

Поделиться сообщением


Ссылка на сообщение

с мг.конфиг-ом - он  живёт как всегда в /var/keys, только надо  поправить параметр на  типа ресивера  на   B: { 12 }

в роутере просто конкретно за свистком закрепить прописыный  в тюнере айпи свистка . Тут сам понимаешь, надо  сидеть и играть ..

Кстати - как с уровнем сигнала на свистке? на простеньком дигилайне с4 и альме2300 при уровне сигнала ниже 50% начинались затыки...

Поделиться сообщением


Ссылка на сообщение

Что за параметр "на типа ресивера на B:{12}"? Где это? Что это? Как это править? Зачем это править? И что это даст?

У свистка сейчас IP 192.168.1.249  В какой закладке это прописывается?

Можно как-то на ресе увидеть сигнал, который получает свисток? Роутер в 5 метрах от свистка. Файлы с реса на комп качаются через свисток нормально и смотреть даже через вебинтерфейс нормально и SD и HD каналы. Но также случаются затыки. Они то часто, а то нет. Спасибо Вам за разъяснения.


@ProFanas,а куда Дядя Фёдор пропал? Почему он решил остановить проект PGI?

Поделиться сообщением


Ссылка на сообщение

Вот если честно, то я бы точно не заморачивался со свистками когда так близко стоит роутер и рес. Шнурок - оно надёжнее. ИМХО

 

что касаемо параметра в - 12.

 

1395167972-clip-92kb.png

 

 

Про Привязку в роутере свистка. Это  как-то так. Меню настройки зависит от твоего девайса

 

1395168397-clip-32kb.png

 

 

 

Что касаемо Дяди Федора, то он тут, и ни куда не пропадал. А проект..

Зачем развивать то, что уже не о что не выпускается, но и компании-производителя  как таковой нет...

Изменено пользователем ProFanas

Поделиться сообщением


Ссылка на сообщение

Знали бы Вы как сильно и как давно я заморочился с Вай-Фай и сколько времени и денег на него и на свистки потратил, Вы бы поняли моё упорство. Раньше всегда смотрел по шнурку, но сейчас рес в другой комнате, хотя видимость роутера есть, но не тащить же шнурок через всю комнату. Хотя, если вопрос с вай-фаем так и не решится, тогда с горечью в душе потяну шнурок.

Вам спасибо за подсказки, вечером буду воплощать в жизнь и напишу о результатах.

А о Дяде Фёдоре спросил потому что чувствую, что он всё равно бы ещё что-нить дельное посоветовал или скриптик написал, который бы держал вай-фай сигнал без срывов.

Поделиться сообщением


Ссылка на сообщение

Тут уже обсуждалось, но все же напомню.

Проще (знали бы вы на сколько!!!!!!) взять точку доступа TP-LINK TL-WR702N 

http://www.tp-linkru.com/products/details/?categoryid=241&model=TL-WR702N

Настроить ее в режиме клиента и подключить к ресу по Ethernet.

Точка доступа питается от USB порта ресивера.

Поделиться сообщением


Ссылка на сообщение

@jon,

Спасибо за информацию. Жаль, что так поздно указали на этот путь. Уже три различных адаптера с разными ревизиями купил за время пока пытался решить этот вопрос. Теперь придётся заказывать этот (что Вы рекомендуете).

Только подскажите, там нет никаких подводных камней, чипов, ревизий, коллизий или ещё чего-то из-за чего работать не будет вся схема или можно спокойно заказывать и придёт именно то, что нужно?!

Не подскажите заодно как можно сей аппарат настроить?

Спасибо!

Поделиться сообщением


Ссылка на сообщение

Там все просто.

Эта точка доступа работает как клиент, подключается к Wi-Fi и раздает по LAN доступ в инет.

Ресивер подключен к ней по LAN и получает питание от USB реса.

Для ресивера все это выглядит как будто он подключен по проводу, т.е. в ресивере настройки как при проводном подключении.

В точке TP-Link тоже все на русском языке настраивается через WEB интерфейс.

Сейчас уже не помню точно как, но если не разберешься, то помогу.

Пиши в личку.

Поделиться сообщением


Ссылка на сообщение

на крайняк можно взять ЛЮБОУЮ точку доступа. нужно будет только лишнюю розетку для блока питания..

Поделиться сообщением


Ссылка на сообщение

Вчера отрыл точку доступа, которая лежала с 2006 года, но настроить не смог. Вроде и вай-фай прописал ей и айпи ноута, но в инет так и не выше. Модуль вай-фай видит точку, а по проводу с ноутом нормально пакетами обмен идёт, а вот роутер не видится. Весь вечер ругался. Настраивал как Client/Repiter.

Поделиться сообщением


Ссылка на сообщение

с мг.конфиг-ом - он  живёт как всегда в /var/keys, только надо  поправить параметр на  типа ресивера  на   B: { 12 }

 

Привет! У меня в этом файле и стоял тот параметр, что Вы указывали B: { 12 }. Значит всё правильно и ничего менять не надо?

Скрин приложен.

post-78917-0-13023600-1395482929_thumb.jpg

Изменено пользователем K400BH

Поделиться сообщением


Ссылка на сообщение

Привет! У меня в этом файле и стоял тот параметр, что Вы указывали B: { 12 }. Значит всё правильно и ничего менять не надо?

Скрин приложен.

Ты писал что подвисает. Я предложил всять этот файл из тех аппаратов, на которых всё ОК, но закидывая подправить параметр В/

Знчит не ясно выразился ..

Поделиться сообщением


Ссылка на сообщение

Знчит не ясно выразился ..

Теперь понятно. Сегодня попробую.

 

По совету jon купил и настроил TP-LINK TL-WR702N, но результат такой же - регулярные подвисания различной степени длительности. Часто приходится нажимать жёлтую кнопку, чтобы рестартовал мжкамд и был запрос на связь с роутером. В общем, полное расстройство. Сегодня пойду сдавать TP-LINK TL-WR702N. Похоже функция вай-фай до конца не реализована программно и нужно покупать длинный кабель и тянуть к роутеру. Очень обидно...

Поделиться сообщением


Ссылка на сообщение

Ну так попробуй закинуть mg.conf от  другого  реса, от того , который не виснет., только подправив  в нём B { 12 }

Поделиться сообщением


Ссылка на сообщение

Файл поменял и заменил в ресе. При старте реса изображение появляется мгновенно, но подвисания так и остались((((

Поделиться сообщением


Ссылка на сообщение

Какой файл в ресе отвечает за отправку паролей через wifi? Может там что-нить поправить нужно? Потому что то мигает диодик на адаптере, то просто горит и в этот момент происходит подвисание и "Канал заблокирован или недоступен".

Поделиться сообщением


Ссылка на сообщение

По совету jon купил и настроил TP-LINK TL-WR702N, но результат такой же - регулярные подвисания различной степени длительности. 

А у тебя точно при подключении проводом подвисаний нет?

Потому что при подключении через автомномную точку доступа ресивер работает как через провод, т.е. он даже не подозревает что инет ему приходит через Wi-Fi.

Если через провод все ок, а через разные точки доступа повисания, то возможно траблы с точкой доступа, которая раздает инет.

 

Для теста кинь времянку проводную и убедись в этом.

Изменено пользователем jon

Поделиться сообщением


Ссылка на сообщение

Для теста кинь времянку проводную и убедись в этом.

Привет! Кидал уж первым делом. Всё работает без тормозов. Более того, два других реса (SEZAM 1000HD и SEZAM MARVEL) оба по Вай-Фай работают безукоризненно. Поэтому-то я и не понимаю в чём дело.

Поделиться сообщением


Ссылка на сообщение

Пропала сеть,купил wifi адаптер edimax ew-7711umn он здесь есть в рекомендованных в списке.написано что должен работать без всяких манипуляций в pgi последней версии финал.однако почитал в доках и понял,что все равно нужно править файлы.кто нибудь точно может пояснить.проблема еще и в том ,что у меня роутер на котором не убирается пароль и соединения нету.роутер huawei hg -532е.кто нибудь подскажет менять роутер или обязательно чинить лан сеть.ресивер ipbox910hd

Поделиться сообщением


Ссылка на сообщение

Приобрел DWA-137 A1A на чипе RT 3070, изменил hardware id 2001:3317 на 07d1:3c16 в файлах все прописал не работает не пойму что неправильно делаю?

В файле /var/interfaces_wlan

iface wlan0 inet static
address 192.168.1.42
netmask 255.255.255.0

 

gateway 192.168.1.1 
В файле /var/etc/Wireless/RT3070STA/
#The word of "Default" must not be removed
Default
CountryRegion=5
CountryRegionABand=7
CountryCode=
ChannelGeography=1
SSID=Network
NetworkType=Infra
WirelessMode=9
Channel=0
BeaconPeriod=100
TxPower=100
BGProtection=0
TxPreamble=0
RTSThreshold=2347
FragThreshold=2346
TxBurst=1
PktAggregate=0
WmmCapable=1
AckPolicy=0;0;0;0
AuthMode=OPEN
EncrypType=NONE
WPAPSK=
DefaultKeyID=1
Key1Type=1
Key1Str=
Key2Type=1
Key2Str=
Key3Type=1
Key3Str=
Key4Type=1
Key4Str=
PSMode=CAM
AutoRoaming=0
RoamThreshold=70
APSDCapable=0
APSDAC=0;0;0;0
HT_RDG=1
HT_EXTCHA=0
HT_OpMode=1
HT_MpduDensity=4
HT_BW=1
HT_BADecline=0
HT_AutoBA=1
HT_BADecline=0
HT_AMSDU=0
HT_BAWinSize=64
HT_GI=1
HT_MCS=33
HT_MIMOPSMode=3
HT_DisallowTKIP=1
EthConvertMode=
EthCloneMac=
IEEE80211H=0
TGnWifiTest=0
WirelessEvent=0
MeshId=MESH
MeshAutoLink=1
MeshAuthMode=OPEN
MeshEncrypType=NONE
MeshWPAKEY=
MeshDefaultkey=1
MeshWEPKEY=
CarrierDetect=0
AntDiversity=0
BeaconLostTime=4
FtSupport=1
Wapiifname=ra0
WapiPsk=
WapiPskType=
WapiUserCertPath=
WapiAsCertPath= 
Команды:
[PGI ~]$ lsusb
 
Bus 001 Device 003: ID 07d1:3c16
 
Bus 002 Device 001: ID 0000:0000
 
Bus 001 Device 001: ID 0000:0000
 
[PGI ~]$ iwconfig
 
eth0      no wireless extensions.
 
 
 
lo        no wireless extensions.
 
 
 
wlan0     RT3070 Wireless  ESSID:""  Nickname:""
 
          Mode:Auto  Frequency=2.412 GHz  
 
          Link Quality=10/100  Signal level:0 dBm  Noise level:-143 dBm
 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
 
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
 
 
[PGI ~]$ ifup -i /var/interfaces_wlan wlan0
 
ifup: interface wlan0 already configured
 
[PGI ~]$ ip a
 
1: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
 
    link/ether 00:13:18:02:e3:4f brd ff:ff:ff:ff:ff:ff
 
    inet 192.168.2.4/24 brd 192.168.2.255 scope global eth0
 
2: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue 
 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 
    inet 127.0.0.1/8 scope host lo
 
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
 
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
 
[PGI ~]$ netstat -rn
 
Kernel IP routing table
 
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
 
192.168.2.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
 
0.0.0.0         192.168.2.1     0.0.0.0         UG        0 0          0 eth0
 
[PGI ~]$ 

Поделиться сообщением


Ссылка на сообщение

если кто еще будет мучаться со сменой vid:pid, выкладываю драйвер сюда, бо старый сайт ralink благополучно помер, а мне тут нужно было кой-че подправить

https://github.com/xiangzhai/rt5370

Изменено пользователем He1ix

Поделиться сообщением


Ссылка на сообщение

Пробовал подружить Ipbox 910HD с 148F:5730.

Менял на 148F:3070 и на 07D1:3C16.

Ipbox видит в любом варианте но соединяться не хочет.

Как только не пробовал.

Может кому пригодиться.

Поделиться сообщением


Ссылка на сообщение

Rt5370? Ну-ну.. Лет 5 назад обсуждали. Спасибо что напомнил.

http://gomel-sat.bz/topic/1342-wi-fi-na-na-proshivkah-pgi/?page=15#comment-505825

Изменено пользователем He1ix

Поделиться сообщением


Ссылка на сообщение

@shmaksimka 3 раза заказывал на alixepress. просто поиск по ralink 3070. почитать отзывы. за 5$ через 2 недели получаем что нужно и радуемся.

Изменено пользователем He1ix

Поделиться сообщением


Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти